Golang alpine Dockerfile 最小打包
创始人
2024-05-29 09:55:30
0次

最近在ubantu 上进行了 iris项目的alpine 版本打包,过程遇到了一些问题,记录一下。
golang版本 :1.18
系统:ubantu

代码结构

在这里插入图片描述

Dockfile内容

FROM alpine:latest
MAINTAINER Si Wei<3320376695@qq.com>
ENV VERSION 1.1
ENV GO111MODULE=on
ENV CGO_ENABLED 0
WORKDIR /app
RUN mkdir -p /usr/share/zoneinfo/Asia/
COPY deploy/Shanghai /usr/share/zoneinfo/Asia/Shanghai
COPY qycloud-irisOps /app/qycloud-irisOps
COPY config /app/config
RUN ln -sf /usr/share/zoneinfo/Asia/Shanghai /etc/localtime
RUN echo 'Asia/Shanghai' >/etc/timezone
ENV LANG C.UTF-8
EXPOSE 8080
ENTRYPOINT ["./qycloud-irisOps"]

错误解决过程

二进制包 qycloud-irisOps 是通过:go build -o qycloud-irisOps 生成的
为啥我的go项目 build打包docker后报这个错误呢
docker: Error response from daemon: failed to create shim: OCI runtime create failed: runc create failed: unable to start container process: exec: “qycloud-irisOps”: executable file not found in $PATH: unknown.

一开始我以为是 文件 ,也就是 ENTRYPOINT [“./qycloud-irisOps”] 这里的问题,在求助同事和朋友之后,很多人第一反应也都是我这里写错了。
在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
根据讨论,我进去容器 去验证了,其实是有这个目录和文件的。 docker run -it --entrypoint "" 镜像名 /bin/sh
在这里插入图片描述

那么问题就不是 entrypoint 和 copy 的问题。 排除dockerfile问题。

问题所在

其实这里not found不是说找不到这个程序,而是找不到需要的动态连接库,
go语言是静态编洋型的语言,即使这个程序非常简单,但是它还是依颜了动态链接库,这个动态链接库是系统内置的,而我编译用的系统是ubantu,要在alipline上运行,在ubuntu上用的是glibc.alpine为了追求轻量,选择了musl libc,因此我的程序无法下常动态链接

所以编译的时候禁用外部函数,静态编译。

在这里插入图片描述
在这里插入图片描述
在这里插入图片描述
综上所述,编译时添加参数CGO_ENABLED=0,关闭CGO就可以了:

# 禁用CGO
CGO_ENABLED=0 go build -o qycloud-irisOps
# 
docker build -t irisops_docker:v1.0 .
docker run -itd --name=irisGo irisops_docker:v1.0

新的问题

在禁用CGO编译之后,确实可以正常起 docker 启动 go 服务了,但是又报了 mysql.go 的链接错误,这是因为

connString := fmt.Sprintf("%s:%s@tcp(%s:%s)/%s?charset=%s&parseTime=True&interpolateParams=true&loc=", c.User, c.Password, c.Host, c.Port, c.Database, c.Charset)connString = connString + "Asia%2FShanghai"var err errorDB, err = gorm.Open("mysql", connString)if err != nil {iris.New().Logger().Error("err is", err)iris.New().Logger().Error("connString is", connString)log.Panic(err)os.Exit(-1)}

这里面 c.Host 的127.0.0.1 在docker中是找不到的,所以 ,改动这里的配置 为 mysql ,然后在 docker run 的时候 改成下面这样 。

docker run --link mysql:mysql -itd --name=irisGo irisops_docker:v1.0

这样mysql报错的问题就解决了。

总结

CGO_ENABLED=0 go build -o qycloud-irisOps -tags netgodocker run -itd --name=irisGo irisops_docker:v1.0docker run --link mysql:mysql -itd --name=irisGo irisops_docker:v1.0

相关内容

热门资讯

前端-session、jwt 目录:   (1)session (2&#x...
linux入门---制作进度条 了解缓冲区 我们首先来看看下面的操作: 我们首先创建了一个文件并在这个文件里面添加了...
关于测试,我发现了哪些新大陆 关于测试 平常也只是听说过一些关于测试的术语,但并没有使用过测试工具。偶然看到编程老师...
前缀和与对数器与二分法 1. 前缀和 假设有一个数组,我们想大量频繁的去访问L到R这个区间的和,...
nodejs:本地安装nvm实... 一、背景-使用不同版本node的原因 vue3+ts、nuxt3版本,node...
JAVA集合知识整理 Java集合知识整理 HashMap相关 HashMap的底层数据结构:jdk1.8之...
无刷直流电机介绍及单片机控制实... 无刷直流电机介绍及单片机控制实例前言基本概念优势与劣势使用寿命基本结构使用单片机控制实例电子调速器&...
fwdiary(2) dp2 1.传纸条  AcWing 275. 传纸条 - AcWing 走两条路,走一条最大的...
常用的DOS命令 常用的DOS命令 DOS(Disk Operating System,磁...
<C++> 类和对象(下) 1.const成员函数将const修饰的“成员函数”称之为const成员函数,cons...